CapsMan настройка

Навигация

Для настройки надо определиться с каналами, обратите внимание каналы в красной рамке запрещены в РФ :

Настройка CapsMan.

CapsMan/Channels добавляем каналы для диапазона 2,4 ГГц:

в консоли:

/caps-man channel add band=2ghz-g/n control-channel-width=20mhz extension-channel=disabled frequency=2412,2437,2462 name=ch-2.4 reselect-interval=1d

То же самое для 5 ГГц:

/caps-man channel add band=5ghz-n/ac frequency=5180,5220,5260,5300,5745,5785 control-channel-width=20mhz extension-channel=XX name=ch-5 reselect-interval=1d

Реализация роуминга в CapsMan основана на отключении пользователя при достижении им критического уровня сигнала, создаем правила в access list:

/caps-man access-list add action=accept disabled=no interface=all signal-range=-69..120
/caps-man access-list add action=reject disabled=no interface=all signal-range=-120..-70

Далее указываем в какой bridge приземлить пользователей Wi-Fi:

/caps-man datapath add bridge=br-wifiauth name=datapath-wifiauth

Создаем профиль безопасности:

/caps-man security add authentication-types=wpa2-psk encryption=aes-ccm group-encryption=aes-ccm name=security-wifiauth passphrase=123456987 group-key-update=1h

Далее создаем конфигурацию сети для интерфейса 2,4 ГГц:

В остальных вкладках выбираем соответствующие вновь созданные настройки:

/caps-man configuration add channel=ch-2.4 datapath=datapath-wifiauth mode=ap name=cfg2.4-wifiauth rx-chains=0,1,2,3 security=security-wifiauth ssid=wifiauth tx-chains=0,1,2,3

То же самое проделываем для интерфейса 5ГГц:

/caps-man configuration add channel=ch-5 datapath=datapath-wifiauth mode=ap name=cfg5-wifiauth rx-chains=0,1,2,3 security=security-wifiauth ssid=wifiauth tx-chains=0,1,2,3

Далее создаем профили автонастройки точек доступа для интерфейсов 2,4 и 5 ГГц:

/caps-man provisioning add action=create-dynamic-enabled hw-supported-modes=b,gn master-configuration=cfg2.4-wifiauth
/caps-man provisioning add action=create-dynamic-enabled hw-supported-modes=an,ac master-configuration=cfg5-wifiauth

Далее включаем CapsMan Manager:

/caps-man manager set enabled=yes

Здесь же можно выбрать интерфейс в котором планируется управлять точками доступа. Также можно заморочится с сертификатами, для того чтобы к CapsMan могли подключиться только точки доступа имеющие сертификат, но это рассмотрим в отдельной статье …

Настройка Cap (клиента CapsMan).

Далее рассмотрим подключение точки доступа, на примере cAPac, которую подключим к CapsMan. Для этого создадим bridge и соберем в него проводные интерфейсы ether1 и ether2.

/interface bridge port add bridge=br-local interface=ether1
/interface bridge port add bridge=br-local interface=ether2

и вешаем в bridge адрес:

/ip address add address=192.168.88.2/24 interface=br-local network=192.168.88.0

ну и остается включить управление точкой доступа:

/interface wireless cap set bridge=br-local caps-man-addresses=192.168.88.1 enabled=yes interfaces=wlan1,wlan2

видим, что беспроводные интерфейсы переходят под управлением CapsMan:

Вам также может понравиться...

Популярные записи