Настройка VLAN, примеры

Навигация

Оригинал статьи здесь.

Сначала создаём bridge с отключенной vlan-filtering, чтобы не потерять доступ к устройству до того, как VLAN будут полностью настроены.

/interface bridge add name=bridge1 vlan-filtering=no

После завершения настроек VLAN Filtering следует включить.

/interface bridge set bridge1 vlan-filtering=yes

1. Trunk and Access Ports

Alt text
  • Добавляем bridge port и указываем pvid для портов с Native VLAN.
/interface bridge port add bridge=bridge1 interface=ether2
/interface bridge port add bridge=bridge1 interface=ether6 pvid=200
/interface bridge port add bridge=bridge1 interface=ether7 pvid=300
/interface bridge port add bridge=bridge1 interface=ether8 pvid=400
  • Добавляем Bridge VLAN указывая тэги на магистральном порту и untagged в сторону компов.
/interface bridge vlan add bridge=bridge1 tagged=ether2 untagged=ether6 vlan-ids=200
/interface bridge vlan add bridge=bridge1 tagged=ether2 untagged=ether7 vlan-ids=300
/interface bridge vlan add bridge=bridge1 tagged=ether2 untagged=ether8 vlan-ids=400

2. Trunk and Hybrid Ports

Alt text
  • Добавляем bridge port и указываем pvid для портов с Native VLAN.
/interface bridge port add bridge=bridge1 interface=ether2
/interface bridge port add bridge=bridge1 interface=ether6 pvid=200
/interface bridge port add bridge=bridge1 interface=ether7 pvid=300
/interface bridge port add bridge=bridge1 interface=ether8 pvid=400
  • Добавляем Bridge VLAN указывая tagged and untagged порты. В этом примере тегируется исходящий трафик в том числе и на портах ether6, ether7, ether8, превращая их в гибридные порты.
/interface bridge vlan add bridge=bridge1 tagged=ether2,ether7,ether8 untagged=ether6 vlan-ids=200
/interface bridge vlan add bridge=bridge1 tagged=ether2,ether6,ether8 untagged=ether7 vlan-ids=300
/interface bridge vlan add bridge=bridge1 tagged=ether2,ether6,ether7 untagged=ether8 vlan-ids=400

3. InterVLAN Routing by Bridge

Alt text
  • Добавляем bridge port и указываем pvid для портов с Native VLAN.
/interface bridge port add bridge=bridge1 interface=ether6 pvid=200
/interface bridge port add bridge=bridge1 interface=ether7 pvid=300
/interface bridge port add bridge=bridge1 interface=ether8 pvid=400
  • Добавляем Bridge VLAN указывая tagged and untagged порты.. В этом примере bridge1 является транковым интерфейсом
/interface bridge vlan add bridge=bridge1 tagged=bridge1 untagged=ether6 vlan-ids=200
/interface bridge vlan add bridge=bridge1 tagged=bridge1 untagged=ether7 vlan-ids=300
/interface bridge vlan add bridge=bridge1 tagged=bridge1 untagged=ether8 vlan-ids=400
  • Создаем интерфейсы VLAN в bridge1 и устанавливаем адреса на этих интерфейсах для возможности маршрутизации трафика.
/interface vlan add interface=bridge1 name=VLAN200 vlan-id=200
/interface vlan add interface=bridge1 name=VLAN300 vlan-id=300
/interface vlan add interface=bridge1 name=VLAN400 vlan-id=400

/ip address add address=20.0.0.1/24 interface=VLAN200
/ip address add address=30.0.0.1/24 interface=VLAN300
/ip address add address=40.0.0.1/24 interface=VLAN400

Вам также может понравиться...

Популярные записи